Mengatasi Error Instalasi laravel/ui di Laravel 6

  • by

Pada posting ini Saya akan memberikan tips bagaimana mengatasi Error Instalasi laravel/ui di Laravel 6. Berikut ini Error yang saya temui:

Problem 1
    - Conclusion: remove laravel/framework v6.18.35
    - Conclusion: don't install laravel/framework v6.18.35
    - laravel/ui 2.x-dev requires illuminate/support ^7.0 -> satisfiable by illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.19.1, v7.2.0, v7.2.1, v7.2.2, v7.20.0, v7.21.0, v7.22.0, v7.22.1, v7.22.2, v7.22.3, v7.22.4, v7.23.0, v7.23.1, v7.23.2, v7.24.0, v7.25.0, v7.3.0, v7.4.0, v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - laravel/ui v2.1.0 requires illuminate/support ^7.0 -> satisfiable by illuminate/support[7.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.0.3, v7.0.4, v7.0.5, v7.0.6, v7.0.7, v7.0.8, v7.1.0, v7.1.1, v7.1.2, v7.1.3, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.19.1, v7.2.0, v7.2.1, v7.2.2, v7.20.0, v7.21.0, v7.22.0, v7.22.1, v7.22.2, v7.22.3, v7.22.4, v7.23.0, v7.23.1, v7.23.2, v7.24.0, v7.25.0, v7.3.0, v7.4.0, v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2].
    - don't install illuminate/support 7.x-dev|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.3|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.4|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.5|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.6|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.7|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.0.8|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.1.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.1.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.1.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.1.3|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.10.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.10.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.10.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.10.3|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.11.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.12.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.13.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.14.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.14.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.15.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.16.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.16.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.17.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.17.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.17.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.18.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.19.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.19.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.2.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.2.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.2.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.20.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.21.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.22.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.22.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.22.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.22.3|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.22.4|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.23.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.23.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.23.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.24.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.25.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.3.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.4.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.5.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.5.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.5.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.6.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.6.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.6.2|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.7.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.7.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.8.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.8.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.9.0|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.9.1|don't install laravel/framework v6.18.35
    - don't install illuminate/support v7.9.2|don't install laravel/framework v6.18.35
    - Installation request for laravel/framework (locked at v6.18.35, required as ^6.0) -> satisfiable by laravel/framework[v6.18.35].
    - Installation request for laravel/ui ^2.1 -> satisfiable by laravel/ui[2.x-dev, v2.1.0].

Hal ini disebabkan versi default laravel/ui yang digunakan saat posting ini dibuat adalah versi 2.1.0. Sedangkan versi ui tersebut (2.1.0) membutuhkan minimal Laravel versi 7. Tapi jangan buru-buru upgrade Laravel ke versi 7, kamu masih bisa menggunakan Laravel 6 ini kok. Caranya adalah dengan men-downgrade versi laravel/ui ke versi 1.0.

composer require laravel/ui "^1.0" --dev

Silahkan copas (Copy Paste) command di atas untuk menginstall laravel/ui versi 1.0 dengan menggunakan composer. Setelah itu jika tampil result seperti di bawah ini, maka instalasi laravel/ui telah sukses.

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Package jakub-onderka/php-console-highlighter is abandoned, you should avoid using it. Use php-parallel-lint/php-console-highlighter instead.
Writing lock file
Generating optimized autoload files
> Illuminate\Foundation\ComposerScripts::postAutoloadDump
> @php artisan package:discover --ansi
Discovered Package: fideloper/proxy
Discovered Package: laravel/tinker
Discovered Package: laravel/ui
Discovered Package: nesbot/carbon
Discovered Package: nunomaduro/collision
Package manifest generated successfully.
38 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Semoga membantu, selamat mencoba. Mari belajar Laravel bersama-sama.

Leave a Reply

Your email address will not be published. Required fields are marked *